Workflow not updating using SharePoint Designer

I recently came across a really frustrating problem where I had to make an update to a workflow that had been in place for a few months (changing the wording in an email that’s sent out).  The strange thing was, the changes never seemed to be applying, the behaviour of the site was such that it always seemed like the “old” workflow was running, even though I had updated it, the wording in the emails were not changing.

I eventually ran across this post:

http://blogs.msdn.com/sharepointdesigner/archive/2007/03/27/tip-clearing-the-spd-workflow-assembly-cache.aspx

Which gave instructions on how to clear the SharePoint Designer Workflow Assembly Cache.  That fixed the problem.

To clear the SPD activity cache:

1. Close SPD.
2. Open “My Computer”.
3. Go to %System Drive%\Documents and Settings\%user%\Local Settings\Application Data\Microsoft\WebSiteCache (If you are running Vista, that path is different – look for %System Drive%\Users\%user%\AppData\Local\Microsoft\WebSiteCache).
4. Go to a directory that looks similar to the name of the website you were connecting to. (Alternatively, you can just delete all these directories and everything should work when you boot SPD).
5. Delete the assembly with the name similar to the one you are changing.
6. Boot SPD.
7. You can now work with your updated activity.

Advertisements

1 Response to “Workflow not updating using SharePoint Designer”


  1. 1 Peter September 9, 2008 at 7:28 pm

    Thank you so much – lifesaver.

    Peter


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s





%d bloggers like this: